Brief issue with 8x8 Meeting connectivity for some users - EMEA region

Incident

Brief issue with 8x8 Meeting connectivity for some users - EMEA region

Status: closed
Start:
End:
Duration: 25 minutes
Affected Components:
Meet
Update

Some 8x8 Meeting participants may have experienced a brief issue with connectivity to 8x8 meeting services in EMEA region. The issue is now resolved and we are investigating the root cause. We apologize for the inconvenience. 

Resolved

Issue is now resolved. Meetings are operating normally.