8x8 Work issues calling VCC numbers

Incident

8x8 Work issues calling VCC numbers

Status: closed
Start:
End:
Duration: 1 hour 1 minute
Affected Components:
APAC Work Calling Outbound
Update

8x8 have received reports that customers are having issues calling certain VCC numbers from their 8x8 Work applications. We are currently investigating and will provide updates as soon as they become available.

Resolved

8x8 have resolved the issue. Please reach out to support if you are still experiencing any issues. We apologize for any inconvenience caused.