issue with receiving inbound calls

Incident

issue with receiving inbound calls

Status: closed
Start:
End:
Duration: 26 minutes
Affected Components:
Americas Work Calling Inbound
Update

A subset of 8x8 customers in the US region experienced an issue with receiving inbound calls to their 8x8 Work PBX. 

Resolved

auto-closed