Inbound calls issue

Incident

Inbound calls issue

Status: closed
Start:
End:
Duration: 12 hours 19 minutes
Affected Components:
Americas Work Calling Inbound
Update

8x8 is investigating inbound call failures to a subset of US 8x8 provided phone numbers. We are currently investigating and will provide updates as they become available.

Update

8x8 has isolated the issue and is working to resolve it. We will continue to provide updates and we apologize for the inconvenience.

Update

8x8 engineers continue to work towards resolution of the issue. We will continue to provide updates as they become available and we apologize for the inconvenience. 

Update

8x8 has already begun the restoration of the identified affected numbers. We expect this process to not be fully completed until after hours pacific time. 8x8 has prioritized restoration for customers who have contacted support and will continue to do so for anybody reporting this issue. If you believe you are impacted please contact support and we will verify and prioritize restoration. We will provide an update at 8:00 pm Pacific Time on the progress of the full restoration of numbers. We apologize for the inconvenience.

Update

8x8 has finished restoration for prioritized numbers prior communicated prior to 2:29 PM Pacific time. 8x8 will continue to finish restoring the full list of impacted phone numbers. We will provide an update on this progress at 8 pm Pacific time

Update

8x8 has seen significant progress on restoring numbers affected and is continuing to restore numbers until completion. Next update will be done at 12:00 AM Midnight pacific time. We again apologize for the inconvenience. 

Resolved

8x8 has confirmed that all phone numbers affected have now been restored. A full root cause is being investigated and we apologize for the impact to customers.