Intermittent page loading issues login.8x8.com

Incident

Intermittent page loading issues login.8x8.com

Status: closed
Start:
End:
Duration: 15 minutes
Affected Components:
Americas SSO
Update

8x8 Is currently investigating a performance issue with some customers having intermittent issues loading the login.8x8.com website. We'll provide updates as they become available. 

Resolved

8x8 observed the impact over a 2 minute window. The issue is now resolve and we are fully reviewing the root cause.