NA20 Inbound calling issues

Incident

NA20 Inbound calling issues

Status: closed
Start:
End:
Duration: 1 hour 11 minutes
Affected Components:
Americas Contact Center Contact Center US2 NA20
Update

8x8 is investigating reports with some NA20 customer experiencing calls failing to complete on inbound calls.  8x8 is currently looking into the issue and updates will be provided as they become available. 

Investigating

8x8 has narrowed the investigation to a select number of tenants on this platform. If you are experiencing issues with inbound calls to your NA20 tenant please contact support to continue troubleshooting. We are continuing to investigate with the identified customers. 

Resolved

8x8 has resolved the inbound calling issues for those customers reporting to 8x8. 8x8 operations is completing a root cause investigation. If any customer continues to experience issues with inbound calling, please contact 8x8 support to continue troubleshooting. We apologize for the inconvenience