8x8 Work calls not completing

Incident

8x8 Work calls not completing

Status: closed
Start:
End:
Duration: 2 hours 17 minutes
Affected Components:
Americas Work Calling Inbound Outbound Endpoints WorkM (VOM) WorkD (VOD) Deskphones
Investigating

8x8 is currently investigating reports of 8x8 Work endpoints not being able to make or receive calls. We are currently investigating and will provide updates as they become available. 

Identified

8x8 has observed a network event causing connectivity issues with 8x8 customers attempting to contact 8x8 services.  We are working to investigate the root cause and will continue to provide updates as they become available. 

Update

8x8 is continuing to investigate connectivity issues with some customers who have not yet been able to connect to 8x8 services after the brief network connectivity issue. We'll continue to investigate and report on the progress of the investigation. We apologize for the issue. 

Monitoring

8x8 has seen recovery for most customers. We are continuing to monitor recovery of customers re-establishing connectivity. If you are still experiencing issues connecting please contact 8x8 via your support tickets to continue troubleshooting. We will continue to post updates as we confirm with customers. 

Monitoring

8x8 has seen restoration of customers reporting connectivity issues. If you are still experiencing  connectivity issues please contact 8x8 support to continue troubleshooting. We'll post a final update to close this incident shortly. 

Resolved

After continued monitoring we have seen all customers connectivity restored. We are now closing this incident and performing a  full root cause investigation. We apologize for the inconvenience.