8x8 Support Portal access issues

Incident

8x8 Support Portal access issues

Status: closed
Start:
End:
Duration: 2 hours 35 minutes
Affected Components:
Americas EMEA APAC Service portals Service portals Service portals Admin Console (AC) Admin Console (AC) Admin Console (AC)
Update

8x8 Is currently investigating an issue with the 8x8 Support Portal not being accessible. We are working on resolving the issue and updates will be provided as they become available. For the time being should you want to contact Support, please explore additional contact methods such as chat. Further details can be found here.

Update

8x8 is continuing to investigate why some select administrators cannot access the My 8x8 portal that includes support case management and billing. Access to 8x8 Admin Console for system configuration changes and all other web services is operational and working as normal. For those impacted that need support please contact 8x8 support over alternate support methods such as Chat and Phone support. Full details can be found at this URL. Contact 8x8 Support Link

Resolved

8x8 has resolved the issue causing login failures to My 8x8 for some selected administrators. All logins functionality is currently operational. If you still need assistance please contact 8x8 support to continue troubleshooting. We are investigating the root cause and we apologize for the inconvenience.