8x8 Admin Console not loading

Incident

8x8 Admin Console not loading

Status: closed
Start:
End:
Duration: 41 minutes
Affected Components:
Americas EMEA APAC Service portals Service portals Service portals Admin Console (AC) Admin Console (AC) Admin Console (AC)
Update

8x8 is investigating reports of the 8x8 Admin Console not loading properly for some customers. Please contact support to investigate this issue while we confirm and update this post with further updates. 

Update

8x8 has confirmed impact to the 8x8 Admin Console that is causing pages to load slowly or to timeout and give an error. 8x8 is currently working to restore normal performance and will provide updates as they become available. 

Update

Our engineers are currently working to resolve the issue as a matter of urgency. We will continue to provide updates as they become available. 

Resolved

8x8 has identified and mitigated the issue causing the sluggish performance with the Admin Console. Currently all pages are now loading within normal performance. We are investigating the full root cause and we apologize for the inconvenience.