8x8 Work Analytics slow to load reports

Incident

8x8 Work Analytics slow to load reports

Status: closed
Start:
End:
Duration: 1 hour 53 minutes
Affected Components:
Americas EMEA Analytics Analytics
Update

8x8 is investigating reports of some analytics reports for large queries taking longer to load or timing out. We are currently investigating and will provide updates as they become available. 

Monitoring

8x8 has implemented mitigation and the analytics is currently now performing normally. We will be monitoring its performance over the next hour. An update will be provide then unless a new update becomes available. 

Resolved

8x8's mitigation has brought stability to loading times and analytics. It is now performing normally. We are investigating the root cause and we apologize for the inconvenience.