Call delays to 8x8 Support Number

Incident

Call delays to 8x8 Support Number

Status: closed
Start:
End:
Duration: 4 hours 6 minutes
Affected Components:
EMEA All Other Services
Update

8x8 Is currently investigating a delay issue when calling the main 8x8 Main UK support line +442070966060 from an external number. We are working on resolving the issue and updates will be provided as they become available. 


Update

Our engineers are currently working to resolve the issue impacting the 8x8 Main UK support line. In the meantime should you have an urgent matter we recommend reaching out to support via Chat until the issue is resolved. Guide attached hereWe will continue to provide updates as they become available.

Resolved

8x8 has resolved the issue delay issue when calling the main 8x8 Main UK support line +442070966060 from an external number.  We apologize for the inconvenience.