Issues making outbound calls to Singapore

Incident

Issues making outbound calls to Singapore

Status: closed
Start:
End:
Duration: 1 hour 40 minutes
Affected Components:
Americas EMEA APAC Work Calling Work Calling Work Calling Outbound Outbound Outbound
Update

8x8 is currently investigating an issue where callers are unable to dial Singapore numbers. We are working with our underlying carriers and will provide updates as soon as they are available.


Update

We are continuing to work with our underlying carriers to address this issue. We appreciate your patience with us and will provide further updates as soon as possible.

Update

Our underlying carrier has identified the issue further upstream. We are continuing to work with them towards a resolution. We will provide updates as soon as they become available.

Resolved

Our underlying carrier has resolved the issue. We have seen improvement in call termination in Singapore. If you are still experiencing issues, please contact Support. We apologize for any inconvenience caused.