8x8 Support Portal not loading (Support.8x8.com)

Incident

8x8 Support Portal not loading (Support.8x8.com)

Status: closed
Start:
End:
Duration: 1 hour 14 minutes
Affected Components:
Americas EMEA APAC All Other Services All Other Services All Other Services
Investigating

8x8 is investigating confirmed reports of the 8x8 Support page at support.8x8.com not loading intermittently. This does not impact 8x8 service delivery functions such as telephony call flow or other 8x8 web services. We are investigating this and will provide updates as they become available. 

Update

8x8 continues to experience issues with the 8x8 Support Site. We'll continue to provide updates as they become available. 

Resolved

8x8 has seen the recovery of the 8x8 Support portal. All pages are now loading as expected. We apologize for the inconvenience.