Connection issues to 8x8 Services

Incident

Connection issues to 8x8 Services

Status: closed
Start:
End:
Duration: 2 hours 4 minutes
Affected Components:
EMEA Work Calling SSO Analytics All Other Services Inbound Outbound
Investigating

8x8 Is currently investigating reports of customers experiencing connection issues to 8x8 services. Please contact support to troubleshoot as we investigate this further. We will provide updates will be provided as they become available. 


Update

8x8 has discovered a large major Tier1 ISP in the EMEA region experiencing performance issues that may be impacting customers' connectivity to 8x8 services. This can cause call quality issues, page loading issues, and prevent Analytics wallboards from updating properly. At this time all 8x8 services are healthy but depending on the path a customer uses to reach 8x8 or the paths between some 8x8 services that utilize this ISP may have issues. 8x8 is currently deprioritizing traffic to the affected ISP to avoid the problem area as much as possible. 8x8 has a limited ability to influence routes through a customer's ISP and could not fully resolve a customer's route around this connection issue. We'll continue to monitor and provide updates as they become available.

Update

8x8 has seen connections over the affected ISP improve. 8x8 has already deprioritized the ISP experiencing the issue. We'll continue to monitor and provide a final update once available. 

Resolved

8x8 has observed that most ISP’s have routed around the problematic connection and most customers should see improved connectivity. While 8x8 has deprioritized traffic away from the affected ISP we will be following up with them for root cause.