8x8 Support portal not loading: https://support-portal.8x8.com/

Information

8x8 Support portal not loading: https://support-portal.8x8.com/

Status: closed
Date:
End:
Duration: 11 minutes
Affected Components:
Americas EMEA APAC 8x8 Website 8x8 Website 8x8 Website
Update

8x8 is aware of it's support portal at https://support-portal.8x8.com/ currently not successfully loading. We are aware of the issue and will provide updates as they become available. 


All 8x8 Admin Console and Contact Center product portals are available as normal. Customers can still contact 8x8 Support via chat, case and phone as normal as well. Your My 8x8 Portal for self service case creation and updates is also available as normal.


US

From within the US: 1-888-898-8733

When prompted, press 1

For General Support press 1

For Technical Support press 2

For Billing press 3

For Number Porting press 4

From outside the US: 1-408-687-4120


Non-US Regional

Australia: +61 1300 088 917 (+61 1800 648 574)

New Zealand: +64 (0)800 452 545

UK: +44 207 096 6060

France:  +33 1 57 96 03 61

Japan: +81 3-4578-9032 

Thailand: +66 2 026 8209

Philippines: +63 2 8271 3494

Singapore: +65 3158 8675

Resolved

8x8 has resolved the issue causing 8x8 Support portal load failures and it is now loading successfully. We are investigating the root cause and we apologize for the inconvenience.