US region Contact Center calling issues US2

Incident

US region Contact Center calling issues US2

Status: closed
Start:
End:
Duration: 23 minutes
Affected Components:
Americas Contact Center Contact Center US2 NA9 NA17 NA38
Identified

8x8 has identified an issue causing telephony issues on a subset of US2 Contact Center clusters. We are currently working to resolve and will provide updates as they become available. 

Monitoring

8x8 has seen recovery and customers impacted should see restoration of their telephony functions. We are currently monitoring and will provide further updates once confirmed. 

Resolved

8x8 has confirmed that the issue is now resolved. Impact was isolated to phone transactions. Other digital channels such as email, chat and SMS were not impacted. We are currently investigating the root cause and we apologize for the interruption.