8x8 Support Portal not loading

Incident

8x8 Support Portal not loading

Status: closed
Start:
End:
Duration: 6 hours 2 minutes
Affected Components:
Americas EMEA APAC 8x8 Website 8x8 Website 8x8 Website
Update

We are aware of an issue impacting our knowledge base support.8x8.com. Operations are currently investigating with priority.

If you need to open a support case, please engage support via https://8x8.my.site.com/. Alternatively, depending on the permissions, support cases can be logged via https://sso.8x8.com/ and open "My 8x8".

Updates will be shared once available.

Investigating

8x8 is currently working to resolve the issue as a matter of urgency.

The support page vendor has been contacted and they acknowledge a problem with their services. 

We will continue to provide updates as they become available.

Investigating

8x8 and the support page vendor continue to work towards resolution of the issue.

We will continue to provide updates as they become available, and we apologize for the inconvenience.

Investigating

8x8 and the support page vendor are actively working to resolve the issue.

We will keep you updated as new information becomes available, and we apologize for any inconvenience this may cause.

Investigating

The support page vendor is experiencing significant outages across multiple service providers, which are linked to a global issue. The vendor is actively troubleshooting the problem with their providers.

We will continue to provide updates as they become available.

Investigating

8x8 has performed extensive testing across multiple clusters and sites, confirming that all login, inbound, and outbound tests, including those involving MS Teams endpoints, have successfully passed. 
For the 8x8 Support Portal issue, the vendor is actively troubleshooting the problem with their providers. 
We will continue to provide updates as they become available.

Update

The support page vendor is continuing to investigate the Issue with their providers. 
8x8 continues to monitor the situation and will provide updates as they become available.

Resolved

The support page vendor has identified and resolved the issue. The 8x8 Support portal is now loading successfully.
We apologize for any inconvenience this may have caused.