Windows 11 update causing call quality issues with 8x8 Work Desktop

Information

Windows 11 update causing call quality issues with 8x8 Work Desktop

Status: closed
Date:
End:
Duration: 5 days 23 hours 14 minutes
Affected Components:
Americas EMEA APAC Work Calling Work Calling Work Calling Endpoints Endpoints Endpoints WorkD (VOD) WorkD (VOD) WorkD (VOD)
Update

8x8 support has observed that a new Windows 11 update rolling out to users has caused 8x8 Work Desktop applications to experience high jitter resulting in degraded call quality. 8x8 has isolated to the recent Windows 11 24H2 update. Customers that have the ability to uninstall this feature should do so to restore normal call quality while a more permanent resolution could be developed. More details can be found in this KB article. Updates will provided in the article as they become available. 

Knowledge Article for Windows 11 24H2 update causing call quality

Update

8x8 has found the root cause of the issue causing call quality with this new Windows update. 8x8 will be developing a new version of the 8x8 Work app for Windows and expects to make it available in the next couple of days. We'll provide a further update when it becomes available. Thank you for your patience on the matter.

Resolved

8x8 has released a new build of version 8.17 of 8x8 Work for windows that contains a patch for this issue. Downloading the latest version will resolve the call quality issue and is available for download or by selecting "help" and "check for updates" option inside the application.

Additional details can be found in the articles below:

8x8 Knowledge Article with more details

Download link to 8x8 Work for Windows