Inbound telephony issues with Canada numbers

Incident

Inbound telephony issues with Canada numbers

Status: closed
Start:
End:
Duration: 28 minutes
Affected Components:
Americas Work Calling All Other Services Inbound
Identified

8x8 has identified an issue impacting a subset of inbound Canadian numbers. The impacted Canadian numbers may receive a busy signal or other error message. We are currently working with our underlying carrier to resolve and will provide updates as they become available. 

Resolved

8x8 has worked with the carrier hosting the impacted numbers and we have confirmed that the issue is now resolved. Inbound calls should be completing as normal in the Canada region. We are working the carrier to investigate root cause and we apologize for the interruption.