8x8 Meetings Unavailable in 8x8 Work Applications

Incident

8x8 Meetings Unavailable in 8x8 Work Applications

Status: closed
Start:
End:
Duration: 1 hour 45 minutes
Affected Components:
APAC Meet
Investigating

We have received reports that 8x8 Meetings is not appearing in 8x8 Work applications. This appears to be limited to users on X1 licences. We are investigating the issue and will provide updates as soon as possible.

Update

We are still investigating this issue. We will provide further updates as they become available. We apologize for any inconvenience caused.

Resolved

We have identified and addressed the issue. Please ask users to relog into 8x8 Work to see the Meetings tab again. We apologize for any inconvenience caused. Please contact 8x8 Support if you are still experiencing issues.