8x8 Support portal is down
Incident
2025-03-25T04:00:00.0000000Z
8x8 Support portal is down
Status: closed
Start:
2025-03-25T03:32:00.0000000Z
End:
2025-03-25T04:00:00.0000000Z
Duration: 28 minutes
Affected Components:
Americas
EMEA
APAC
8x8 Website
8x8 Website
8x8 Website
Investigating
2025-03-25T03:32:00.0000000Z
2025-03-25T03:32:00.0000000Z
The 8x8 support portal (https://support-portal.8x8.com/) is currently unavailable. We are investigating this issue and will provide updates as they become available.
Resolved
2025-03-25T04:00:00.0000000Z
2025-03-25T04:00:00.0000000Z
The 8x8 support portal has been restored. We apologise for any inconvenience caused.
Copyright (C) 2022.