8x8 Voicemail and Call recording media not available

Incident

8x8 Voicemail and Call recording media not available

Status: closed
Start:
End:
Duration: 11 days 2 minutes
Affected Components:
Americas Analytics All Other Services
Identified

8x8 has identified an issue causing a subset of customer voicemail and call recordings to become unavailable for playback. This media is being recorded, however transcoding of the media for playback is delayed. 8x8 is working with it's cloud provider on restoring real-time availability for customers. 8x8 Work voicemails can be listened to via this alternate method in the knowledge article below:

Access Voicemail from Your Phone

8x8 will continue to provide updates as they become available. 


Update

Our engineers are currently working to resolve the issue as a matter of urgency. As a reminder 8x8 Work voicemails can be listened to via this alternate method in the knowledge article below.

Access Voicemail from Your Phone

We will continue to provide updates as they become available. 

Update

8x8 has resolved availability of media recorded prior to last night 4-27-2025 11:00PM EDT Eastern time. (8:00 PM Pacific). Recordings and Voicemail media recorded before this time stamp is available.

8x8 is currently working to restore access to media recorded between 4-27-2025 11:00PM EDT and 2025-04-28 13:45 EDT. This media is still missing and we'll provide an update on the progress of it's restoration. 

New media recorded after 2025-04-28 13:45 EDT is currently being transcribed and has a 1-2 hour delay for availability. 

We'll continue to provide updates as they become available. 

Update

Media recorded  between: 2025-04-28 10:22 AM EDT  and  2025-04-28 15:10 PM EDT is still not available as 8x8 continues to work to restore this media. 

8x8 also continues to work to restore newly recorded media that has be recorded after 2025-04-28 15:10 EDT . This media is being processed and being populated for your availability but with a delay. We estimate about a 2-3 hour delay in it's availability. 

8x8 will provide an update of this media's availability next at 8:00PM EDT (5:00PM Pacific) or if a new update becomes available. We apologize for the interruption. 


Identified

The issue with  recordings and voicemails being delayed for playback is now resolved. All newly recorded media is available in real-time under normal performance standards. 

Recordings and voicemails recorded between:  2025-04-28 10:22 AM EDT  and  2025-04-28 15:10 PM EDT are still being recovered. We will provide an update on this progress 4-29-2025 at 8:00 AM PDT. We apologize for the interruption while we work to fully resolve this issue. 

Update

8x8 has investigated and begun the process of reconstructing the missing media that has not yet been made available for playback. 8x8 estimates that this data may take 1-2 days to fully propagate and become available. This only impacts media recorded between 2025-04-28 10:22 AM EDT and 2025-04-28 15:10 PM EDT.

8x8 will continue to provide daily updates until all data is restored. Our next update will be on April 30, 2025, at 8:00 AM PDT. We apologize for the interruption.

Update

8x8 is continuing data synchronization for the missing time period. This activity will continue over the following days, and we are currently working on a more accurate estimated date for availability. We will provide daily updates or as new information becomes available. The remaining impact applies only to media recorded between 2025-04-28 10:22 AM EDT and 2025-04-28 3:10 PM EDT.

Update

8x8 continues working on reconstructing the missing data for the media recorded between 2025-04-28 10:22 AM EDT and 2025-04-28 3:10 PM EDT. We will continue providing daily updates or as new information becomes available. We apologize for the inconvenience.

Update

8x8 continues the effort in reconstructing the missing data for the media recorded between 2025-04-28 10:22 AM EDT and 2025-04-28 3:10 PM EDT. We are following through a multi-step approach that requires more time than anticipated in order to successfuly restore the missing data. We apologize yet again for the inconvenience and we will continue to provide updates as new information becomes available.

Resolved

8x8 has completed the restoration of the missing media. All media recorded between 2025-04-28 10:22 AM EDT and 2025-04-28 3:10 PM EDT is now available for playback. We apologize for the inconvenience and 8x8 is working to implement steps to prevent issues of this nature in the future.