Inability to assign new numbers to eFax

Incident

Inability to assign new numbers to eFax

Status: closed
Start:
End:
Duration: 2 hours 58 minutes
Affected Components:
Americas Fax WorkD and WorkM Fax
Investigating

8x8 is currently investigating a customer-impacting incident on eFax affecting customers across the US regions.

Users are experiencing an inability to assign new numbers to eFax for any account.

eFax numbers already assigned are not impacted.

Updates will be provided as they become available.

Update

Our engineers are working to resolve the issue as soon as possible. We will continue to provide updates as they become available. 

Update

We are doing our very best to get this issue resolved as a matter of priority, we thank you for your patience. We will provide further update as they become available and we again apologize for the inconvenience. 

Resolved

8x8 has resolved the issue causing the failures when assigning numbers to the eFax services for users. New assignments are now successful. 8x8 has released numbers that have previously failed to assign. If you encountered the error previously, please log into the 8x8 Admin Console and reassign the numbers. If you encounter any further issues or need assistance please contact  8x8 support to continue troubleshooting. 

We are performing a root cause investigation and we apologize for the inconvenience.