Microsoft Teams endpoint calling issues

Incident

Microsoft Teams endpoint calling issues

Status: closed
Start:
End:
Duration: 43 minutes
Affected Components:
EMEA Work Calling Endpoints Deskphones
Identified

8x8 has reopened it's previous incident where EU West Microsoft Teams endpoints experienced issues with making and receiving calls. We are currently working to resolve and will provide updates as they become available. 

For the time being initial checks show that users can utilize 8x8 Work Windows and MacOS applications or use 8x8 Work Web as a work around.

8x8 Work can be logged in at work.8x8.com

8x8 Work application can be downloaded here: https://support.8x8.com/business-phone/voice/work-desktop/download-8x8-work-for-desktop

Resolved

8x8 has worked it's integration partner and has confirmed additional mitigation has resolved the issue. The mitigation we believe will ensure stability until the root cause is identified. 8x8 will be working to complete this root cause investigation in the next 7 days and we apologize for the inconvenience.