8x8 Knowledge website Maintenance: support-portal.8x8.com
Maintenance
2025-06-02T07:30:00.0000000Z
8x8 Knowledge website Maintenance: support-portal.8x8.com
Status: closed
Start:
2025-06-02T07:00:00.0000000Z
End:
2025-06-02T07:30:00.0000000Z
Duration: 30 minutes
Affected Components:
Americas
EMEA
APAC
8x8 Website
8x8 Website
8x8 Website
Update
2025-06-02T07:00:00.0000000Z
2025-06-02T07:00:00.0000000Z
The 8x8 Support Portal knowledgebase at https://support-portal.8x8.com/ will be undergoing maintenance and will not be available for approximately 30 minutes starting at 9:000 AM CEST (12:00 AM PDT) on June 2nd, 2025. All other 8x8 services will be available and no service will be impacted. Support is available for any assistance during this time.
US
- From within the US: 1-888-898-8733
- When prompted, press 1
- For General Support press 1
- For Technical Support press 2
- For Billing press 3
- For Number Porting press 4
- When prompted, press 1
- From outside the US: 1-408-687-4120
Non-US Regional
- Australia: +61 1300 088 917 (+61 1800 648 574)
- New Zealand: +64 (0)800 452 545
- UK: +44 207 096 6060
- France: +33 1 57 96 03 61
- Japan: +81 3-4578-9032
- Thailand: +66 2 026 8209
- Philippines: +63 2 8271 3494
- Singapore: +65 3158 8675
Resolved
2025-06-02T07:30:00.0000000Z
2025-06-02T07:30:00.0000000Z
8x8 has completed the 8x8 Knowledgebase maintenance. Accessibility is back to normal.
Copyright (C) 2022.