Cannot create new Support Tickets in My 8x8 support Portal.

Information

Cannot create new Support Tickets in My 8x8 support Portal.

Status: closed
Date:
End:
Duration: 1 hour 46 minutes
Affected Components:
Americas EMEA APAC 8x8 Website 8x8 Website 8x8 Website
Update

8x8 Support is currently investigating an issue preventing the creation of new support tickets in the My 8x8 support portal. We are currently working to restore this ability. In the meantime you can contact 8x8 Support via chat or phone. 8x8 services are fully operational and not impacted. 

Contacting 8x8 Support


Resolved

8x8 has resolved the issue and customers can now create support tickets as normal. We will investigate the root cause and we apologize for the inconvenience.