Delays reaching 8x8 Phone Support
Information
2025-07-01T17:49:00.0000000Z
Delays reaching 8x8 Phone Support
Status: closed
Date:
2025-07-01T15:20:00.0000000Z
End:
2025-07-01T17:49:00.0000000Z
Duration: 2 hours 29 minutes
Affected Components:
Americas
EMEA
APAC
All Other Services
All Other Services
All Other Services
Update
2025-07-01T15:20:00.0000000Z
2025-07-01T15:20:00.0000000Z
8x8 currently is experiencing issues answering phone calls via 8x8 phone support channel. If you need immediate support please open a support ticket by visiting your My 8x8 Support portal to engage.
Resolved
2025-07-01T17:49:00.0000000Z
2025-07-01T17:49:00.0000000Z
8x8 phone support service levels are back to normal. We apologize for the inconvenience.
Copyright (C) 2022.