8x8 Outbound call issues

Incident

8x8 Outbound call issues

Status: closed
Start:
End:
Duration: 8 hours 42 minutes
Affected Components:
EMEA Work Calling Outbound
Investigating

8x8 Is currently investigating reports of agents being unable to place outbound calls, line showing as disconnected when attempting to do so. We are working on resolving the issue and updates will be provided as they become available. 


Update

The outbound calling issue was confirmed with our carriers as being external. Inbound calling is expected to be working as normal. We will continue to investigate and updates will be provided as they become available. 

Update

Our engineers are currently working to resolve the issue as a matter of urgency. We will continue to provide updates as they become available. 

Update

One of our carriers has confirmed there is an ongoing network incident with one of their partners. Inbound calls are not affected. All other systems are running normally. We will continue to investigate and updates will be provided as they become available. 

Update

We continue the collaboration with our carriers in order to resolve the issue. We will continue to provide updates as they become available and we apologize for the inconvenience. 

Update

We continue the collaboration with our carriers in order to resolve the issue. We will continue to provide updates as they become available and we apologize for the inconvenience. 

Update

We continue to work with our carriers in order to resolve the issue with calling in the region. To ensure you are fully informed of the progress being made, we will provide you with regular updates via this platform every 60 minutes or until a significant update becomes available.

Update

We are doing our very best to ensure we get updates on resolution as soon as possible and we thank you for your patience. To ensure you are fully informed of the progress being made, we will provide you with regular updates via this platform every 120 minutes or until a significant update becomes available. 

Resolved

8x8 has seen stability and our underlying carrier has declared resolution. We have not had any further reports of outbound call completion issues in the region. We are following up with our underlying carrier for root cause investigation and we apologize for the interruption.