Call Quality Issues Contact Centre EMEA

Incident

Call Quality Issues Contact Centre EMEA

Status: closed
Start:
End:
Duration: 34 minutes
Affected Components:
EMEA Contact Center Contact Center UK3 EU4 EU14 EU13 EU12 EU11 EU10 EU5 EU6 EU7 EU8 EU9
Investigating

Dear Customer

We are currently investigating an incident impacting calls, where users might experience call quality issues and call disconnection on our contact centre product.

We are working on resolving the issue and updates will be provided as they become available. 

Regards

8x8 Support






Resolved

Our teams have identified and resolved the issue.

If you continue to experience issues, please contact our 8x8 Support Team.

We apologise for the inconvenience caused.