Microsoft Teams performance issues

Information

Microsoft Teams performance issues

Status: closed
Date:
End:
Duration: 5 hours 44 minutes
Affected Components:
Americas All Other Services
Update

8x8 has received reports from 8x8 Users utilizing MS Teams voice integrations having performance issues. 8x8 Systems are operating normally and Microsoft has acknowledged performance issues that they are investigating directly. Please reference the update from Microsoft directly at the links below. If you are having issues with microsoft endpoints if possible you can switch to utilizing 8x8 Work Web for 8x8 Agent Workspace endpoints as an alternative. 

https://status.cloud.microsoft/

https://x.com/MSFT365Status/status/2080313098351575176?s=20

8x8 endpoint alternatives. 

Work Web instructions

8x8 Agent Workspace instructions

Resolved

Microsoft has resolved their incident. For root cause please contact Microsoft support via the Microsoft Admin Center portal.