My8x8 missing in the Application Panel
Incident
2026-07-24T10:38:00.0000000Z
My8x8 missing in the Application Panel
Status: closed
Start:
2026-07-24T10:19:00.0000000Z
End:
2026-07-24T10:38:00.0000000Z
Duration: 19 minutes
Affected Components:
Americas
EMEA
Service portals
Service portals
Admin Console (AC)
Admin Console (AC)
Investigating
2026-07-24T10:19:00.0000000Z
2026-07-24T10:19:00.0000000Z
8x8 Is currently investigating reports where the My8x8 app is missing from the Application Panel. We are working on resolving the issue and updates will be provided as they become available.
Resolved
2026-07-24T10:38:00.0000000Z
2026-07-24T10:38:00.0000000Z
8x8 has resolved the issue impacting My8x8. We are monitoring and investigating the root cause and we apologize for the inconvenience.
Copyright (C) 2025.