Telephony issues in US Region for Contact Center Cusotmers

Incident

Telephony issues in US Region for Contact Center Cusotmers

Status: closed
Start:
End:
Duration: 2 hours 19 minutes
Affected Components:
Americas Contact Center Contact Center US1 Contact Center US2 NA1 NA7 NA2 NA8 NA3 NA9 NA4 NA10 NA5 NA17 NA6 NA18 NA11 NA19 NA12 NA20 NA13 NA27 NA14 NA28 NA15 NA29 NA37 NA16 SB1 NA38 NA30 NA39
Investigating

8x8 is currently experiencing telephony issues affecting Contact Center customers in the US Region. We are currently investigating and will provide updates as they become available. 

Investigating

8x8 engineers continue to work towards resolution of the issue. We will continue to provide updates as they become available and we apologize for the inconvenience. 

Monitoring

8x8 has implemented mitigation and are working to confirm resolution with customers. All telephony should now be operating normally. If you are still experiencing issues, please contact 8x8 support to confirm symptoms and troubleshooting further. We'll post a final update once fully confirmed. 

Monitoring

8x8 continues to see stability with call traffic in the US region. If you are still experiencing issues, please contact 8x8 support to confirm symptoms and troubleshooting further.  We'll continue to monitor and provide further updates once fully confirmed. 

Resolved

8x8 has confirmed resolution. US Telephony traffic has remained stable since 1:47 PM PDT (4:47 PM EDT). We are performing a full root cause investigation and we apologize for the interruption.